Bug 1837451

Summary: golang http clients break on goaway
Product: OpenShift Container Platform Reporter: David Eads <deads>
Component: kube-apiserverAssignee: David Eads <deads>
Status: CLOSED ERRATA QA Contact: Ke Wang <kewang>
Severity: high Docs Contact:
Priority: high    
Version: 4.5CC: aos-bugs, mfojtik, xxia
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:40:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Eads 2020-05-19 13:30:27 UTC
https://github.com/golang/go/issues/39086

We should remove our filter.

Comment 3 Ke Wang 2020-05-25 09:40:56 UTC
Verified with OCP 4.5.0-0.nightly-2020-05-24-223848,  steps see below,

$ configyaml=$(oc get configmaps/config  -n openshift-kube-apiserver -o json | jq .data.'"config.yaml"')

$ echo $configyaml | sed 's/^\"*//;s/\"*$//' | xargs echo | jq . | grep -C3 goaway
      "SCTPSupport=true",
      "LegacyNodeRoleBehavior=false"
    ],
    "goaway-chance": [
      "0"
    ],
    "http2-max-streams-per-connection": [

Comment 4 errata-xmlrpc 2020-07-13 17:40:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409