Bug 1841097

Summary: [sig-cli] oc adm must-gather runs successfully test failing because of missing "default" SA
Product: OpenShift Container Platform Reporter: Michal Fojtik <mfojtik>
Component: ocAssignee: Michal Fojtik <mfojtik>
Status: CLOSED ERRATA QA Contact: zhou ying <yinzhou>
Severity: high Docs Contact:
Priority: high    
Version: 4.5CC: aos-bugs, jokerman, malonso, maszulik, mfojtik
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:42:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michal Fojtik 2020-05-28 11:06:38 UTC
Description of problem:

[It] runs successfully [Suite:openshift/conformance/parallel]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/cli/mustgather.go:34
May 27 04:55:26.805: INFO: Running 'oc --namespace=e2e-test-oc-adm-must-gather-bgc86 --kubeconfig=/tmp/admin.kubeconfig adm must-gather --dest-dir /tmp/test.oc-adm-must-gather.626916323'
May 27 04:55:28.928: INFO: Error running /usr/bin/oc --namespace=e2e-test-oc-adm-must-gather-bgc86 --kubeconfig=/tmp/admin.kubeconfig adm must-gather --dest-dir /tmp/test.oc-adm-must-gather.626916323:
[must-gather      ] OUT Using must-gather plugin-in image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:4c3f27c5e62325b5e0e27aab367ede7591a539de7d8bb2c30c77d956f61e524b
[must-gather      ] OUT namespace/openshift-must-gather-2mxsn created
[must-gather      ] OUT clusterrolebinding.rbac.authorization.k8s.io/must-gather-mvtqq created
[must-gather      ] OUT clusterrolebinding.rbac.authorization.k8s.io/must-gather-mvtqq deleted
[must-gather      ] OUT namespace/openshift-must-gather-2mxsn deleted
Error from server (Forbidden): pods "must-gather-" is forbidden: error looking up service account openshift-must-gather-2mxsn/default: serviceaccount "default" not found
[must-gather      ] OUT Using must-gather plugin-in image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:4c3f27c5e62325b5e0e27aab367ede7591a539de7d8bb2c30c77d956f61e524b
[must-gather      ] OUT namespace/openshift-must-gather-2mxsn created
[must-gather      ] OUT clusterrolebinding.rbac.authorization.k8s.io/must-gather-mvtqq created
[must-gather      ] OUT clusterrolebinding.rbac.authorization.k8s.io/must-gather-mvtqq deleted
[must-gather      ] OUT namespace/openshift-must-gather-2mxsn deleted
Error from server (Forbidden): pods "must-gather-" is forbidden: error looking up service account openshift-must-gather-2mxsn/default: serviceaccount "default" not found


Version-Release number of selected component (if applicable):

4.5

How reproducible:

Matched 5.31% of failing runs and 25.00% of jobs in last 7 days.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 zhou ying 2020-06-16 02:19:08 UTC
Checked the testgrid, still could reproduce the error, please see:

https://deck-ci.apps.ci.l2s4.p1.openshiftapps.com/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-4.6/124

Comment 5 Maciej Szulik 2020-06-16 08:39:45 UTC
This is one occurrence from the test grid https://testgrid.k8s.io/redhat-openshift-ocp-release-4.6-blocking#release-openshift-ocp-installer-e2e-aws-4.6&sort-by-flakiness=
from Jun 6th where it looks like the code wasn't properly synced, yet. It's impossible for this path to fail at this place given the fix linked in this PR.
I've checked the test grid and with the rate failure of this particular tests there's nothing to be worried about, I've noticed only 2 failures in the 
past 3 weeks. Moving this back for verification.

Comment 7 zhou ying 2020-06-19 05:20:58 UTC
Maciej Szulik :

Thanks , check the test grid again, no more new failed in the latest few days , will verify it .

Comment 8 errata-xmlrpc 2020-07-13 17:42:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409