Bug 1841572

Summary: calibre fails to start
Product: [Fedora] Fedora Reporter: william.garber
Component: calibreAssignee: Kevin Fenzi <kevin>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 32CC: chkr, enpontus, helio, kevin, nikperrakis, nushio, william.garber, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-29 22:45:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description william.garber 2020-05-29 13:30:44 UTC
Description of problem:

calibre program fails to start

Version-Release number of selected component (if applicable):

$ calibre --version
calibre (calibre 4.13)


How reproducible:

always

Steps to Reproduce:
1. $ calibre
2. fails to start
3.

Actual results:

$ calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib64/calibre/calibre/gui_launch.py", line 72, in calibre
    main(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 542, in main
    listener = create_listener()
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 513, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib64/calibre/calibre/utils/ipc/server.py", line 109, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'


Expected results:

launch program

Additional info:

tried removing all plugins and contents of
~/.config/calibre
~/.local/.../calibre
and 
# dnf remove calibre
followed by
# dnf install calibre

so fresh install does not help.

Comment 1 Nikolaos Perrakis 2020-05-29 21:43:24 UTC
I experience the same error. A re-install didn't help either.

Comment 2 Nikolaos Perrakis 2020-05-29 22:37:58 UTC
Update

Trying to install older fc32 builds from https://kojipkgs.fedoraproject.org/packages/calibre/ didn't work. They either installed and failed to start with the same error or had dependency problems.

I was able to install calibre-4.16.0-2.fc33.x86_64 by:
$ sudo dnf remove calibre
$ sudo dnf install calibre --releasever=33

After that calibre works (but I hope I didn't make my Fedora installation too Frankenstein).

P.S. Dependencies such as python3-qt5-webengine moved from 5.13.x to 5.14.x, maybe it's the latest 5.13.x. Don't know how relevant that is.

Comment 3 Kevin Fenzi 2020-05-29 22:45:42 UTC

*** This bug has been marked as a duplicate of bug 1840780 ***