Bug 1842889

Summary: Add perl-Data-Stream-Bulk to EPEL7
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-Data-Stream-BulkAssignee: Emmanuel Seyman <emmanuel>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: emmanuel, iarnell, perl-devel
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-Data-Stream-Bulk-0.11-22.el7 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-30 01:15:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1843171, 1843173    
Bug Blocks: 1842881    

Description Petr Pisar 2020-06-02 10:41:54 UTC
I need perl-Data-Stream-Bulk for perl-Net-Amazon-S3 in EPEL-7. Would you be so nice and build it for EPEL 7?

Comment 1 Emmanuel Seyman 2020-06-02 18:01:42 UTC
A scratch build against EPEL7 fails with the following errors:

DEBUG util.py:600:  No matching package to install: 'perl(DBIx::Class)'
DEBUG util.py:600:  No matching package to install: 'perl(Test::TempDir)'

I'll file a bug for both these packages.

Comment 2 Petr Pisar 2020-06-03 08:23:27 UTC
DBIx::Class only seems to be an optional test:

Data-Stream-Bulk-0.11 $ grep -Hnr DBIx::Class
t/dbic.t:9:    DBIx::Class
t/dbic.t:23:                    use base qw(DBIx::Class);
t/dbic.t:34:                    use base qw(DBIx::Class::Schema);
lib/Data/Stream/Bulk.pm:242:L<DBIx::Class::ResultSet> iteration.
lib/Data/Stream/Bulk.pm:266:L<DBI>, L<DBIx::Class::ResultSet>
lib/Data/Stream/Bulk/DBIC.pm:56:This is a wrapper for L<DBIx::Class::ResultSet> that fits the
lib/Data/Stream/Bulk/DBIC.pm:62:If L<DBIx::Class::Cursor> will support n-at-a-time fetching as opposed to

$ cat -n  t/dbic.t |head
     1  #!/usr/bin/perl
     2
     3  use strict;
     4  use warnings;
     5
     6  use Test::More;
     7
     8  use Test::Requires qw(
     9      DBIx::Class
    10      DBI

Comment 3 Fedora Update System 2020-06-14 14:03:10 UTC
FEDORA-EPEL-2020-bf39c9dd56 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-bf39c9dd56

Comment 4 Fedora Update System 2020-06-15 02:13:18 UTC
perl-Data-Stream-Bulk-0.11-22.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-bf39c9dd56

Comment 5 Fedora Update System 2020-06-30 01:15:36 UTC
FEDORA-EPEL-2020-bf39c9dd56 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.