Bug 1845819

Summary: Azure-file mount fail on RHEL worker due to missing cifs-utils package
Product: OpenShift Container Platform Reporter: Wei Duan <wduan>
Component: InstallerAssignee: Russell Teague <rteague>
Installer sub component: openshift-ansible QA Contact: Wei Duan <wduan>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: medium CC: aos-bugs, chaoyang, rteague, xtian
Version: 4.4   
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: On the Azure platform, the cifs-utils package is required to create volume mounts for pods. Consequence: Pod volume mounts fail if the package is not installed. Fix: Add cifs-utils to the list of packages installed for RHEL7 hosts when installing OpenShift. Result: Pod volume mounts are created successfully when deploying on the Azure platform.
Story Points: ---
Clone Of: 1827982 Environment:
Last Closed: 2020-06-23 00:57:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1827982    
Bug Blocks: 1845821    

Comment 3 Wei Duan 2020-06-16 04:17:37 UTC
Verified pass on 4.4.0-0.nightly-2020-06-15-203705

In scaleup:
Installing : cifs-utils-6.2-10.el7.x86_64

In rhel works:
sh-4.2# rpm -qa | grep -i cifs-utils 
cifs-utils-6.2-10.el7.x86_64

Comment 5 errata-xmlrpc 2020-06-23 00:57:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580