Bug 1845830

Summary: [azure-file] "Permission denied" when read/write to mounted directory on RHEL node.
Product: OpenShift Container Platform Reporter: Wei Duan <wduan>
Component: InstallerAssignee: Russell Teague <rteague>
Installer sub component: openshift-ansible QA Contact: Wei Duan <wduan>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: aos-bugs, gpei, jsafrane, rteague
Version: 4.5   
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
SELinux permissions were blocking read/write access to mounted volumes on the Azur platform. SELinux booleans are updated to match RHCOS 8.x to allow proper access.
Story Points: ---
Clone Of: 1839965 Environment:
Last Closed: 2020-06-23 00:57:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1839965    
Bug Blocks: 1845836    

Comment 3 Wei Duan 2020-06-16 04:21:24 UTC
Verified pass on 4.4.0-0.nightly-2020-06-15-203705

In scaleup log:
TASK [openshift_node : Setting sebool virt_use_samba] **************************
Tuesday 16 June 2020  11:19:02 +0800 (0:00:02.220)       0:05:50.921 ********** 
changed: [10.0.1.7] => {"changed": true, "name": "virt_use_samba", "persistent": true, "state": true}
changed: [10.0.1.6] => {"changed": true, "name": "virt_use_samba", "persistent": true, "state": true}

TASK [openshift_node : Setting sebool container_use_cephfs] ********************
Tuesday 16 June 2020  11:19:06 +0800 (0:00:03.773)       0:05:54.695 ********** 
changed: [10.0.1.6] => {"changed": true, "name": "container_use_cephfs", "persistent": true, "state": true}
changed: [10.0.1.7] => {"changed": true, "name": "container_use_cephfs", "persistent": true, "state": true}

On rhel worker node:
[wduan@MINT config]$ oc debug node/wduan0611c-hdpfl-rhel-0
sh-4.2# getsebool virt_use_samba
virt_use_samba --> on
sh-4.2# getsebool container_use_cephfs
container_use_cephfs --> on

Comment 5 errata-xmlrpc 2020-06-23 00:57:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580