Bug 1845923

Summary: No way to check installed kuryr-k8s-controller package version within pod
Product: OpenShift Container Platform Reporter: Michał Dulko <mdulko>
Component: NetworkingAssignee: Michał Dulko <mdulko>
Networking sub component: kuryr QA Contact: GenadiC <gcheresh>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: low CC: gcheresh, ltomasbo, rekhan, rlobillo
Version: 4.3.0   
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1845921 Environment:
Last Closed: 2020-07-14 16:11:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1845921    
Bug Blocks:    

Comment 7 rlobillo 2020-07-07 09:20:40 UTC
Verified on OCP4.3.0-0.nightly-2020-07-06-074036:

(overcloud) [stack@undercloud-0 ~]$ oc get pods -n openshift-kuryr
NAME                                READY   STATUS    RESTARTS   AGE
kuryr-cni-4jwgl                     1/1     Running   0          18h
kuryr-cni-5ncjr                     1/1     Running   0          18h
kuryr-cni-lwvrs                     1/1     Running   2          18h
kuryr-cni-ml5kg                     1/1     Running   2          18h
kuryr-cni-mpljs                     1/1     Running   1          18h
kuryr-cni-zm4r7                     1/1     Running   4          18h
kuryr-controller-77ff6978f8-h7wsj   1/1     Running   3          18h

(overcloud) [stack@undercloud-0 ~]$ oc rsh -n openshift-kuryr kuryr-controller-77ff6978f8-h7wsj 
sh-4.4$ kuryr-k8s-controller --version
4.3.28
sh-4.4$ python3 -m pip freeze | grep kuryr
The directory '/var/lib/kuryr/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
kuryr-kubernetes==4.3.28
kuryr-lib==1.1.1
sh-4.4$

Comment 9 errata-xmlrpc 2020-07-14 16:11:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2872