Bug 1846420

Summary: Re-vendor dependencies for manifest and code generation with go modules
Product: OpenShift Container Platform Reporter: Kiran Thyagaraja <kiran>
Component: Bare Metal Hardware ProvisioningAssignee: Kiran Thyagaraja <kiran>
Bare Metal Hardware Provisioning sub component: cluster-api-provider QA Contact: Raviv Bar-Tal <rbartal>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: medium CC: zbitter
Version: 4.6Keywords: OtherQA, Triaged
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:06:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kiran Thyagaraja 2020-06-11 14:42:31 UTC
After Cluster-api-provider-baremetal moved to go-modules with BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1828003, some features such as CRD and deep-copy generation was omitted.

This ticket tracks the PR to address this oversight.
https://github.com/openshift/cluster-api-provider-baremetal/pull/72

Comment 3 Raviv Bar-Tal 2020-08-25 13:58:29 UTC
Hey, Kiran,
Please advice on the verifiaction steps
Is there a test QE can do downstream for this change?
If not, is the change working for you? if this is the case I will verify this Bz with other_qa tag

Thanks in advance 
Raviv

Comment 4 Kiran Thyagaraja 2020-08-25 14:38:31 UTC
Hi Raviv,
This PR fixed couple things in the repo. Both of them are Makefile targets that worked before we moved to go modules.

Basically this functionality already existed before we moved to go modules. This PR fixed the:

make generate
make manifests

targets that used to work before we converted the project to go modules.

Thanks.
Kiran

Comment 6 errata-xmlrpc 2020-10-27 16:06:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196