Bug 1848117 (CVE-2020-14415)

Summary: CVE-2020-14415 QEMU: division by zero in oss_write() in audio/ossaudio.c
Product: [Other] Security Response Reporter: Mauro Matteo Cascella <mcascell>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: ailan, amit, berrange, cfergeau, dbecker, drjones, dwmw2, imammedo, itamar, jen, jferlan, jforbes, jjoyce, jmaloy, jschluet, kbasil, knoel, lhh, lkundrak, lpeer, m.a.young, mburns, mkenneth, mrezanin, mst, pbonzini, ribarry, rjones, robinlee.sysu, sclewis, slinaber, virt-maint, virt-maint, vkuznets, xen-maint
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: qemu 5.0.0 Doc Type: If docs needed, set a value
Doc Text:
A divide-by-zero flaw was found in the Open Sound System (OSS) implementation of the QEMU emulator. A guest user or process may use this flaw to crash the QEMU process on the host, resulting in a denial of service.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-17 23:21:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1848118, 1910686    
Bug Blocks: 1792938    

Description Mauro Matteo Cascella 2020-06-17 17:28:25 UTC
A divide-by-zero flaw was found in function oss_write() in audio/ossaudio.c, resulting in a possible crash and denial of service scenario.

Upstream fix:
https://git.qemu.org/?p=qemu.git;a=commit;h=7a4ede0047a8613b0e3b72c9d351038f013dd357

Comment 1 Mauro Matteo Cascella 2020-06-17 17:28:59 UTC
Created qemu tracking bugs for this issue:

Affects: fedora-all [bug 1848118]

Comment 2 Mauro Matteo Cascella 2020-06-17 17:31:35 UTC
Acknowledgments:

Name: Ziming Zhang

Comment 3 Mauro Matteo Cascella 2020-06-18 09:46:05 UTC
Statement:

Open Sound System (OSS) is deprecated in favor of ALSA and disabled in Red Hat products. This flaw did not affect the following versions of QEMU as they did not include support for OSS:
* `qemu-kvm-ma` as shipped with Red Hat Enterprise Linux 7.
* `qemu-kvm-rhev` as shipped with Red Hat Virtualization and Red Hat OpenStack.
* `qemu-kvm` as shipped with Red Hat Enterprise Linux 6, 7 and 8.
* `virt:8.2/qemu-kvm` as shipped with RHEL Advanced Virtualization.