Bug 1848615

Summary: dnf numeric variable substitutions are undocumented
Product: Red Hat Enterprise Linux 8 Reporter: Davide Cavalca <davide>
Component: dnfAssignee: Marek Blaha <mblaha>
Status: CLOSED ERRATA QA Contact: Radek Bíba <rbiba>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: CentOS StreamCC: bstinson, carl, james.antill, nsella, pkratoch
Target Milestone: rcKeywords: Triaged
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-4.2.23-3.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-04 01:53:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Davide Cavalca 2020-06-18 15:51:46 UTC
https://dnf.readthedocs.io/en/latest/conf_ref.html#repo-variables documents the use of substitution variables like DNF_VAR_foo, but it doesn't mention numeric variables (like DNF0 / DNF1) at all. The only actual mention I found is in https://github.com/rpm-software-management/dnf/blob/c438466a239175fc4ad61b7607d80378a56b7b3f/tests/conf/test_substitutions.py

For reference, the substitutions logic is here: https://github.com/rpm-software-management/dnf/blob/c438466a239175fc4ad61b7607d80378a56b7b3f/dnf/conf/substitutions.py

Comment 2 Marek Blaha 2020-07-14 07:12:17 UTC
PR https://github.com/rpm-software-management/dnf/pull/1637 enhances repo variables documentation

Comment 10 errata-xmlrpc 2020-11-04 01:53:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (yum bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:4510