Bug 1850672

Summary: libvirt: Make master disk size configurable
Product: OpenShift Container Platform Reporter: Praveen Kumar <prkumar>
Component: InstallerAssignee: Praveen Kumar <prkumar>
Installer sub component: openshift-installer QA Contact: Praveen Kumar <prkumar>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: adahiya
Version: 4.5   
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
: 1850862 (view as bug list) Environment:
Last Closed: 2020-07-13 17:44:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1850862    
Bug Blocks:    

Description Praveen Kumar 2020-06-24 16:59:11 UTC
A user should able to specify the volume size of master node by configuring the machineset like they can do it for other cloud providers. Also this will be really useful for crc usecase where disk size needs to be expand after installation.


```
$ openshift-install create manifests --dir mydir
$ yq write --inplace mydir/openshift/99_openshift-cluster-api_master-machines-0.yaml spec.providerSpec.value.volume[volumeSize] 32212254720
$ openshift-install create cluster --dir mydir
```

Comment 5 Praveen Kumar 2020-06-29 05:10:50 UTC
I have verified it on 4.5 side and it works as expected for libvirt.

Comment 6 errata-xmlrpc 2020-07-13 17:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409