Bug 1850862

Summary: libvirt: Make master disk size configurable
Product: OpenShift Container Platform Reporter: Praveen Kumar <prkumar>
Component: InstallerAssignee: Abhinav Dahiya <adahiya>
Installer sub component: openshift-installer QA Contact: Praveen Kumar <prkumar>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified CC: adahiya, jialiu
Version: 4.6   
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1850672 Environment:
Last Closed: 2020-10-27 16:09:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1850672    

Description Praveen Kumar 2020-06-25 04:46:03 UTC
+++ This bug was initially created as a clone of Bug #1850672 +++

A user should able to specify the volume size of master node by configuring the machineset like they can do it for other cloud providers. Also this will be really useful for crc usecase where disk size needs to be expand after installation.


```
$ openshift-install create manifests --dir mydir
$ yq write --inplace mydir/openshift/99_openshift-cluster-api_master-machines-0.yaml spec.providerSpec.value.volume[volumeSize] 32212254720
$ openshift-install create cluster --dir mydir
```

Comment 4 Praveen Kumar 2020-06-30 11:01:56 UTC
This is verified and working as expected.

Comment 6 errata-xmlrpc 2020-10-27 16:09:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196