Bug 1851031

Summary: blender-2.83.1 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: blenderAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: design-devel, kwizart, luya_tfz, negativo17, promac
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: blender-2.83.1-1.fc32 blender-2.83.1-1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-06 01:01:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Upstream Release Monitoring 2020-06-25 13:12:30 UTC
Latest upstream release: 2.83.1
Current version/release in rawhide: 2.82a-5.fc33
URL: http://download.blender.org/source/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/201/

Comment 1 Upstream Release Monitoring 2020-06-25 13:14:00 UTC
The following Sources of the specfile are not valid URLs so we cannot automatically build the new version for you.  Please use URLs in your Source declarations if possible.

- blender.thumbnailer
- blender-fonts.metainfo.xml
- blender.xml
- macros.blender

Comment 2 Fedora Update System 2020-06-27 17:58:21 UTC
FEDORA-2020-57d19f91f7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-57d19f91f7

Comment 3 Fedora Update System 2020-06-27 17:58:23 UTC
FEDORA-2020-663a252550 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-663a252550

Comment 4 Fedora Update System 2020-06-28 01:10:12 UTC
FEDORA-2020-663a252550 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-663a252550`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-663a252550

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-06-28 01:56:50 UTC
FEDORA-2020-57d19f91f7 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-57d19f91f7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-57d19f91f7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Nicolas Chauvet (kwizart) 2020-07-01 09:50:10 UTC
FYI current luxrender 2.3 is incompatible with this version:
https://github.com/LuxCoreRender/BlendLuxCore

I've removed the blender macro usage because assuming that a recompilation of Luxrender will make it compatible with blender is false.
There is a need to adapt the BlendLuxCore code.

Unfortunately we cannot predict if blender will be compatible with LuxRender before testing or upstream mention the compatibility matrix.
This information was only set one week ago (in the README.md).

So I would advocate for a better update policy coordination with blender.
Such that we only update rawhide on new version and backport in stable Fedora branches once blender 2.N.x where x > 2 is launched.
Or any other idea ?

Comment 7 Luya Tshimbalanga 2020-07-01 16:38:17 UTC
(In reply to Nicolas Chauvet (kwizart) from comment #6)
> FYI current luxrender 2.3 is incompatible with this version:
> https://github.com/LuxCoreRender/BlendLuxCore
> 
> I've removed the blender macro usage because assuming that a recompilation
> of Luxrender will make it compatible with blender is false.
> There is a need to adapt the BlendLuxCore code.
> 
> Unfortunately we cannot predict if blender will be compatible with LuxRender
> before testing or upstream mention the compatibility matrix.
> This information was only set one week ago (in the README.md).
> 
> So I would advocate for a better update policy coordination with blender.
> Such that we only update rawhide on new version and backport in stable
> Fedora branches once blender 2.N.x where x > 2 is launched.
> Or any other idea ?

Although there is no objection about manually using the version for Blender, blender-macros-rpm is still needed for installation of BlendLuxCore
for luxcorerender.spec:

# Import add-ons and preset
mkdir -p %{buildroot}%{blender_addons}/%{name}
cp -a BlendLuxCore-blendluxcore_v%{version}%{?prerelease}/* \
  %{buildroot}%{blender_addons}/%{name}

Comment 8 Fedora Update System 2020-07-06 01:01:59 UTC
FEDORA-2020-663a252550 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-07-06 01:39:57 UTC
FEDORA-2020-57d19f91f7 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.