Bug 1851140

Summary: "foreman-rake katello:publish_unpublished_repositories" is referring to column which no longer exists in katello_repositories table.
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: RepositoriesAssignee: James Jeffers <jjeffers>
Status: CLOSED ERRATA QA Contact: Bruno Rocha <rochacbruno>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.6.0CC: jjeffers, jsherril, mmccune, pcreech, wclark
Target Milestone: 6.7.2Keywords: Regression, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tfm-rubygem-katello-3.14.0.21-1,tfm-rubygem-katello-3.14.0.23-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1789911 Environment:
Last Closed: 2020-07-30 20:21:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 4 jcallaha 2020-07-17 14:29:40 UTC
verified in Satellite 6.7.2

The rake command now runs successfully

# foreman-rake katello:publish_unpublished_repositories
#

Additionally, the entire repository file has no references to the old field.

# grep url /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.14.0.24/lib/katello/tasks/repository.rake
          .where.not(katello_root_repositories: { url: nil }).find_each do |repo|

Comment 6 errata-xmlrpc 2020-07-30 20:21:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3255