Bug 1851464

Summary: Beaker inserts <system_type "machine"> despite <system><type></system>
Product: [Community] Beaker Reporter: Jiri Jaburek <jjaburek>
Component: schedulerAssignee: Martin Styk <mastyk>
Status: CLOSED NEXTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: bpeck, cbouchar, jkriz, mastyk
Target Milestone: 28.0   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-29 14:58:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jiri Jaburek 2020-06-26 15:28:07 UTC
Description of problem:

Schedule a job which has

  <hostRequires>
    <and>
      <system>
        <type op="=" value="Resource"/>
      </system>
    </and>
  </hostRequires>

Beaker will not detect this as it probably only expects the older <system_type/>, so the final job XML will have:

  <hostRequires>
    <and>
      <system>
        <type op="=" value="Resource"/>
      </system>
    </and>
    <system_type value="Machine"/>
  </hostRequires>

and it will Abort due to no systems being both Machine and Resource. :)


Version-Release number of selected component (if applicable):
Beaker 27.4

Comment 1 Martin Styk 2020-06-29 14:58:58 UTC
Fix for this issue will be featured in part of Beaker 28.