Bug 1852792

Summary: Should forbidden to create the KubeletConfig object if lack of the evictionSoftGracePeriod when using the soft eviction
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NodeAssignee: Harshal Patil <harpatil>
Status: CLOSED ERRATA QA Contact: MinLi <minmli>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.4CC: aos-bugs, bandrade, chezhang, jokerman
Target Milestone: ---Keywords: Reopened
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: evictionSoft must be specified with corresponding evictionSoftGracePeriod Consequence: Kubelet will fail to start without valid configuration Fix: During KubeletConfig creation verify that evictionSoft is supplied with corresponding evictionSoftGracePeriod Result: Kubelet should start normally with evictionSoft support
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-25 06:20:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1852787    
Bug Blocks:    

Comment 6 MinLi 2020-08-17 07:42:00 UTC
verified in version : 4.4.0-0.nightly-2020-08-15-035358

status:
  conditions:
  - lastTransitionTime: "2020-08-17T07:37:14Z"
    message: 'Error: KubeletConfiguration: evictionSoft[nodefs.inodesFree] is defined
      but EvictionSoftGracePeriod[nodefs.inodesFree] is not set'
    status: "False"
    type: Failure
  - lastTransitionTime: "2020-08-17T07:40:41Z"
    message: 'Error: KubeletConfiguration: EvictionSoftGracePeriod must be set when
      evictionSoft is defined, evictionSoft: map[memory.available:90% nodefs.available:90%
      nodefs.inodesFree:90%]'
    status: "False"
    type: Failure

Comment 8 errata-xmlrpc 2020-08-25 06:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3440