Bug 1853887

Summary: Cinnamon 4.6.5 makes make external display flickering
Product: [Fedora] Fedora Reporter: Marco Guazzone <marco.guazzone>
Component: cinnamon-desktopAssignee: leigh scott <leigh123linux>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: jcpunk, leigh123linux, marco.guazzone
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: cinnamon-desktop-4.6.2-2.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-07 01:05:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marco Guazzone 2020-07-05 08:13:47 UTC
Description of problem:

I have a Dell E5430 laptop with an external fulll HD display that I use as the primary (and only) screen (that is, the screen of my laptop is turned off).
Unfortunately, the new version of Cinnamon makes my external display flickering.

Version-Release number of selected component (if applicable):

cinnamon-4.6.5

How reproducible:

Use a laptop with an external display as the only turned on screen, and upgrade to version 4.6.5 of Cinnamon.

Steps to Reproduce:
1. Use a laptop with an external display
2. Turn off the laptop display and use only the external display.
3. Reboot and enter the Cinnamon desktop environment

Actual results:

The screen flickers, with half screen blue and the other half screen showing (a half of) my background image. The desktop is essentially unusable as windows are partially hidden in the blue part of the screen.

Expected results:

No flickering and all windows are fully

Additional info:

I tried to create a new user (so as to use a fresh new Cinnamon configuration), but the problem is still present.
If I use Gnome (Classic), then I log out and I enter in Cinnamon, the problem disappears; however, if I reboot Fedora and I enter in Cinnamon the problem appears again.
No problem with version 4.4 of Cinnamon.

Related issue on GitHub: https://github.com/linuxmint/cinnamon/issues/9402

Comment 1 Fedora Update System 2020-07-05 08:15:25 UTC
FEDORA-2020-f2738e4da2 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f2738e4da2

Comment 2 Marco Guazzone 2020-07-06 11:25:43 UTC
Sorry, I don't understand the above message.
Should I manually downgrade to Cinnamon 4.6.2 by running: sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f2738e4da2 ?

Comment 3 leigh scott 2020-07-06 12:26:13 UTC
The command updates the cinnamon-desktop package

Comment 4 Marco Guazzone 2020-07-06 19:13:25 UTC
Thanks!
Just installed the above update. It works.

Comment 5 Fedora Update System 2020-07-07 01:05:50 UTC
FEDORA-2020-f2738e4da2 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.