Bug 1855304

Summary: Machine Config operator parses kubelet.conf reducing usability.
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NodeAssignee: Urvashi Mohnani <umohnani>
Status: CLOSED ERRATA QA Contact: MinLi <minmli>
Severity: high Docs Contact:
Priority: low    
Version: 4.4CC: aos-bugs, dahernan, jokerman, minmli, schoudha, umohnani
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-05 10:54:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1834533    
Bug Blocks:    

Comment 3 MinLi 2020-07-14 01:48:24 UTC
Hi, Scott Dodson,  Urvashi Mohnani 

We have a high-importance level automation script which need to check kubelet.conf in 4.x
So we expect this fix can backport to 4.3, or else this script always fail in 4.3, and it's a repetitive work for us to develop a specific script only apply to 4.3
Thanks

Comment 4 Scott Dodson 2020-07-17 13:28:59 UTC
In that case I've raised severity to high then. That's the only thing that patch manager should need to pay attention to so making sure that it meets the requirements for the release is important.

Comment 7 MinLi 2020-07-20 08:36:07 UTC
verified in version : 4.3.0-0.nightly-2020-07-17-210547

Comment 9 errata-xmlrpc 2020-08-05 10:54:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.3.31 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3180