Bug 1855543

Summary: set invalid value for reserved resource in kubeletconfig will succeed
Product: OpenShift Container Platform Reporter: Harshal Patil <harpatil>
Component: NodeAssignee: Harshal Patil <harpatil>
Status: CLOSED ERRATA QA Contact: MinLi <minmli>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: aos-bugs, erich, jokerman, minmli, mpatel, rkrawitz, rphillips, schoudha
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1745919 Environment:
Last Closed: 2020-08-24 15:13:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1745919    
Bug Blocks:    

Comment 5 MinLi 2020-08-17 07:27:05 UTC
verified in version : 4.5.0-0.nightly-2020-08-15-052753

status:
  conditions:
  - lastTransitionTime: "2020-08-17T07:20:52Z"
    message: 'Error: KubeletConfiguration: cpu reservation value cannot be negative
      in kubeReserved'
    status: "False"
    type: Failure
  - lastTransitionTime: "2020-08-17T07:25:06Z"
    message: 'Error: KubeletConfiguration: invalid value specified for cpu reservation
      in kubeReserved, 100++sdm'
    status: "False"
    type: Failure

Comment 7 errata-xmlrpc 2020-08-24 15:13:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.7 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3436