Bug 1857651

Summary: [oVirt] Installer fails when overriding template due to terraform error
Product: OpenShift Container Platform Reporter: Gal Zaidman <gzaidman>
Component: InstallerAssignee: Gal Zaidman <gzaidman>
Installer sub component: OpenShift on RHV QA Contact: Lucie Leistnerova <lleistne>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: unspecified CC: jzmeskal
Version: 4.6   
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:15:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gal Zaidman 2020-07-16 09:32:31 UTC
Description of problem:
PR https://github.com/openshift/installer/pull/3868 added the tmp vm as an output variable. This cause the installer to fail when that resource is not created i.e when we don't let the installer create the template, like we do on CI.
This caused all 4.6 and master PR to be red and fail before starting the installtion.
We need to fix and add a condition to set the var only when the resource is created

Comment 3 Gal Zaidman 2020-07-30 11:07:02 UTC
Verified on CI

Comment 5 errata-xmlrpc 2020-10-27 16:15:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196