Bug 1859790

Summary: RHHI deployment issues debugging chapter-17.3 & 17.4 needs step to clean engine deployment
Product: [Red Hat Storage] Red Hat Gluster Storage Reporter: SATHEESARAN <sasundar>
Component: doc-Deploying_RHHIAssignee: Disha Walvekar <dwalveka>
Status: CLOSED ERRATA QA Contact: SATHEESARAN <sasundar>
Severity: high Docs Contact:
Priority: unspecified    
Version: rhhiv-1.8CC: asriram, dwalveka, rhs-bugs
Target Milestone: ---   
Target Release: RHHI-V 1.8   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-11 13:15:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1785234    

Description SATHEESARAN 2020-07-23 02:25:04 UTC
Description of problem:
-------------------------

Deployment issues debugging chapter 17.3 and 17.4 needs a small change
1. When engine deployment fails in 17.3 and 17.4, the left over engine installation should be cleaned up. For this the command "# ovirt-hosted-engine-cleanup" should be used.

2. Ensure rhvm-appliance is installed on all the hosts. It is enough to install rhvm-appliance only on the host used for deployment. (i.e) cockpit - web console corresponding to the host with which the deployment is initiated.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
All flavors of RHHI deploy doc

Expected results:
------------------
1. Information to be added to clean engine failed installation 17.3 and 17.4
# ovirt-hosted-engine-cleanup

2. Update that says ensure to install rhvm-appliance on all the hosts.

Additional info:

Comment 1 SATHEESARAN 2020-07-23 02:28:40 UTC
There is no cleanup with HE deployment wizard.

So remove the step that says:

"Click Clean up to remove any potentially incorrect changes to the system. "

Comment 2 SATHEESARAN 2020-07-23 02:40:07 UTC
(In reply to SATHEESARAN from comment #1)
> There is no cleanup with HE deployment wizard.
> 
> So remove the step that says:
> 
> "Click Clean up to remove any potentially incorrect changes to the system. "

I mean no cleanup button on the HE deployment wizard. So remove the corresponding step

Comment 3 SATHEESARAN 2020-07-23 02:46:47 UTC
Also there is no 'Redeploy' button available.

If user encounters any errors in 17.3 or 17.4 then they need to fix the problem, perform proper cleanup of failed hosted engine installation using the command - 'ovirt-hosted-engine-cleanup',
close that failed deployment wizard and then proceed to redeploy HE using the option using - 'Use existing configuration' of hyperconverged deployment

Comment 5 SATHEESARAN 2020-07-30 02:53:20 UTC
Hi Disha,

Still I see the section "Failed to prepare virtual machine"  needs correction

Existing content:
-----------------
     * Review the Web Console output for error information. 
     * Click Redeploy and correct any entered values that may have caused errors. If you need help resolving errors, contact Red Hat Support with details.
     * Ensure that the rhvm-appliance package is available on the first hyperconverged host.
         # yum install rhvm-appliance
     * Return to Hosted Engine deployment to try again.
            
       If you closed the deployment wizard while you resolved errors, you can select Use existing configuration when you retry the deployment process.


Expected corrected content
---------------------------
     * Review the Web Console output for error information. 
     * Click 'Back' correct any entered values that may have caused errors. Ensure proper values for network configurations are provided in 'VM' tab.
       If you need help resolving errors, contact Red Hat Support with details.
     * Ensure that the rhvm-appliance package is available on the first hyperconverged host.
         # yum install rhvm-appliance
     * Return to Hosted Engine deployment to try again.
             
       If you closed the deployment wizard while you resolved errors, you can select Use existing configuration when you retry the deployment process.

Comment 6 Disha Walvekar 2020-07-30 09:30:50 UTC
Hi Sas, 

I have made the changes as per the above comment 5, please check the links

1. Automating RHHI for Virtualization deployment -- https://access.redhat.com/documentation/en-us/red_hat_hyperconverged_infrastructure_for_virtualization/1.8/html-single/automating_rhhi_for_virtualization_deployment/index?lb_target=preview#failed_to_prepare_virtual_machine

2. Deploying Red Hat Enterprise Linux based RHHI for Virtualization -- https://access.redhat.com/documentation/en-us/red_hat_hyperconverged_infrastructure_for_virtualization/1.8/html-single/deploying_red_hat_enterprise_linux_based_rhhi_for_virtualization/index?lb_target=preview#failed_to_prepare_virtual_machine

3. Deploying Red Hat Enterprise Linux based RHHI for Virtualization on a single node -- https://access.redhat.com/documentation/en-us/red_hat_hyperconverged_infrastructure_for_virtualization/1.8/html-single/deploying_red_hat_enterprise_linux_based_rhhi_for_virtualization_on_a_single_node/index?lb_target=preview#failed_to_prepare_virtual_machine

4. Deploying Red Hat Hyperconverged Infrastructure for Virtualization -- https://access.redhat.com/documentation/en-us/red_hat_hyperconverged_infrastructure_for_virtualization/1.8/html-single/deploying_red_hat_hyperconverged_infrastructure_for_virtualization/index?lb_target=preview#failed_to_prepare_virtual_machine


5. Deploying Red Hat Hyperconverged Infrastructure for Virtualization on a single node -- https://access.redhat.com/documentation/en-us/red_hat_hyperconverged_infrastructure_for_virtualization/1.8/html-single/deploying_red_hat_hyperconverged_infrastructure_for_virtualization_on_a_single_node/index?lb_target=preview#failed_to_prepare_virtual_machine

Thank you!

-Disha W

Comment 7 SATHEESARAN 2020-07-30 09:48:07 UTC
The change looks good.

The content is now updated with the clear cleanup information