Bug 1860401

Summary: supply python3-libmodulemd package in a repository
Product: Red Hat Enterprise Linux 8 Reporter: Gerd v. Egidy <gerd>
Component: libmodulemdAssignee: Stephen Gallagher <sgallagh>
Status: CLOSED CURRENTRELEASE QA Contact: swm-qe
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.2CC: ppisar, sgallagh
Target Milestone: rc   
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libmodulemd-2.9.4-2.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-28 14:07:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gerd v. Egidy 2020-07-24 13:17:27 UTC
Description of problem:
Currently libmodulemd is part of the BaseOS repo and libmodulemd-devel is part of CodeReady/PowerTools. But python3-libmodulemd, which is built using the same libmodulemd.src.rpm, is not supplied in any repo.

This makes it hard to use, as the user has to recompile it from source. Please add it to a repository, for example to CodeReady/PowerTools, but any of the others would be fine by me too.

I need python3-libmodulemd to build and use modulemd-tools. modulemd-tools makes building and maintaining custom repositories, that are module-enabled, much easier.

I have no problem building modulemd-tools myself. As this is not included in any repo, there are no conflicts to be expected with an in-repo package. But as libmodulemd is in repo, providing my own copy of python3-libmodulemd has a much higher probability of creating conflicts when a newer version is supplied in BaseOS and CodeReady/PowerTools.

Version-Release number of selected component (if applicable):
libmodulemd-2.8.2-1


Steps to Reproduce:
dnf install python3-libmodulemd

Actual results:
Error: Unable to find a match: python3-libmodulemd

Expected results:
package can be installed

Comment 1 Radek Bíba 2020-07-24 14:38:50 UTC
Yes, it's a known issue, and python3-libmodulemd will be in RHEL 8.3. Please wait for the next release.

Comment 3 Petr Pisar 2021-04-28 14:07:35 UTC
python3-libmodulemd-2.9.4-2.el8 is available in AppStream repository since RHEL 8.3.0.