Bug 1862896

Summary: cluster-monitoring-operator: make generate breaks on non-GNU systems
Product: OpenShift Container Platform Reporter: Sergiusz Urbaniak <surbania>
Component: MonitoringAssignee: Pawel Krupa <pkrupa>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.6CC: alegrand, anpicker, erooth, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:22:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sergiusz Urbaniak 2020-08-03 07:42:13 UTC
Recently we removed `make generate-in-docker` to using native tooling instead. This broke for some users as we require GNU's tool chain to make it work.

We need to document the required toolchain in the README and potentially use a more tolerant tool, i.e. sed.

Comment 1 Sergiusz Urbaniak 2020-08-03 07:43:11 UTC
Note this refers to building cluster-monitoring-operator and does not have effect on runtime behavior.

Comment 4 Junqi Zhao 2020-08-05 10:17:34 UTC
it is added in README, close this bug

Comment 6 errata-xmlrpc 2020-10-27 16:22:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196