Bug 1866539

Summary: VSphere IPI fails to bootstrap workers: default resource pool resolves to multiple instances, please specify
Product: OpenShift Container Platform Reporter: Abhinav Dahiya <adahiya>
Component: InstallerAssignee: Aditya Narayanaswamy <anarayan>
Installer sub component: openshift-installer QA Contact: jima
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: adeshpan, anarayan, andcosta, bward, daharmon, david.barreda, dphillip, dsimmons, jcall, jima, jmalde, lscorsin, mbagga, nbhatt, padillon, rkshirsa, tcort, vpagar
Version: 4.5   
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
When the machines try to get the resourcePoolPath, it finds multiple resource pools and is unable to resolve the right one. Adding a property in the machine sets with the resourcePoolPath information so the right one is picked.
Story Points: ---
Clone Of: 1852545 Environment:
Last Closed: 2020-08-17 20:05:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1852545    
Bug Blocks:    

Comment 4 jima 2020-08-10 05:06:35 UTC
Verified on nightly build 4.5.0-0.nightly-2020-08-07-024812 and passed.

# oc get machinesets.machine.openshift.io  jima45ipi0808-hdhxz-worker -n openshift-machine-api --template '{{.spec.template.spec.providerSpec.value.workspace.resourcePool}}'
/dc1/host/devel/Resources

Comment 6 errata-xmlrpc 2020-08-17 20:05:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3330