Bug 1867201

Summary: Routes created via the webconsole set route.spec.port.targetPort to the service.spec.ports.port
Product: OpenShift Container Platform Reporter: emahoney
Component: Management ConsoleAssignee: Robb Hamilton <rhamilto>
Status: CLOSED ERRATA QA Contact: Siva Reddy <schituku>
Severity: high Docs Contact:
Priority: urgent    
Version: 4.4CC: aos-bugs, bperkins, farandac, gparente, jokerman, mfisher, mifiedle, mjahangi, mmasters, nmukherj, rhowe, scuppett, spadgett, wsun
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
: 1868034 (view as bug list) Environment:
Last Closed: 2020-10-27 16:26:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1868034    

Description emahoney 2020-08-07 17:01:13 UTC
Description of problem:
After upgrading from 4.3 to 4.4 nightly, the server directive in haproxy.conf backend is not picking up endpoints/pods. 

~~~~
Good haproxy.config file 
~~snippet~~~

backend be_edge_http:da-saas-dev-apigee:da-saas-dev-us-login-ui
  http-request set-header X-Forwarded-Proto-Version h2 if { ssl_fc_alpn -i h2 }
  http-request add-header Forwarded for=%[src];host=%[req.hdr(host)];proto=%[req.hdr(X-Forwarded-Proto)]
  cookie 4d647911d32fe9d240f81a98ba8a37a5 insert indirect nocache httponly secure

  server pod:login-ui-4-gc4tt:login-ui-svc:172.20.57.101:8081 172.20.57.101:8081 cookie 3a6baad05e3bfd9d4b5ae8a65489c811 weight 256  <======== pod entry 

Bad haproxy.config file 
~~~snippet~~~
  http-request add-header Forwarded for=%[src];host=%[req.hdr(host)];proto=%[req.hdr(X-Forwarded-Proto)]
  cookie 0d9795a3241921a94276bd5cdbc98145 insert indirect nocache httponly
.....   <========== No pod entry 
~~~~

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-07-30-212136

How reproducible:
Intermittent. The customer noticed that they were able to delete routes and occasionally they would populate the haproxy.conf on their ingress routers. 

Steps to Reproduce:
1. Create route/svc with pod backing it
2. oc rsh pod and vi haproxy.conf
3.

Actual results:
server directive is missing / routes not working

Expected results:
server directive exists with pod/endpoint and routes redirect to the pod/endpoint. 


Additional info:
must-gather, ingress controller logs, haproxy logs, haproxy.config will be linked.

Comment 36 errata-xmlrpc 2020-10-27 16:26:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196