Bug 1868353

Summary: [v2v][ui]kubevirt-vmware objects are not cleaned
Product: OpenShift Container Platform Reporter: Yaacov Zamir <yzamir>
Component: Console Kubevirt PluginAssignee: Filip Krepinsky <fkrepins>
Status: CLOSED ERRATA QA Contact: Ilanit Stein <istein>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: aos-bugs, fkrepins, gouyang, istein, pkliczew
Target Milestone: ---Flags: istein: needinfo+
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:28:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Yaacov Zamir 2020-08-12 11:28:20 UTC
Description of problem:
V2VVMWare or OvirtProvider objects are not cleaned up

when the label cnv.io/temporary: "true" is provided a back end garbage collector should clean up V2VVMWare or OvirtProvider objects after 1 hour.

we should make sure the UI label the temporary objects currectly

back end bug to make sure the labels are repected: https://bugzilla.redhat.com/show_bug.cgi?id=1868045

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-08-12 11:31:39 UTC
cc:// @Piotr @Filip @Ilanit

Comment 2 Piotr Kliczewski 2020-08-12 11:43:47 UTC
Thanks!

Comment 3 Filip Krepinsky 2020-08-12 11:46:55 UTC
thanks, just updated the PR to link to this BZ

Comment 4 Yaacov Zamir 2020-08-13 10:13:25 UTC
https://github.com/openshift/console/pull/6317 merged upstream

Comment 5 Yaacov Zamir 2020-08-13 10:14:39 UTC
https://github.com/openshift/console/pull/6296 is not merged yet ...

Comment 8 Ilanit Stein 2020-10-01 17:32:07 UTC
Verified on CNV-2.5 deployed on Sep 30 2020.

Entered the VM import wizard, picked VM from VMware/RHV providers, and closed the browser window.

$ oc get ovirtproviders.v2v.kubevirt.io
$ oc get V2VVMWare.v2v.kubevirt.io

showed that after 1 hours both object were indeed removed.

Comment 10 errata-xmlrpc 2020-10-27 16:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196