Bug 1869633

Summary: A change VM's boot order while it's running shows a change in disks/NICs
Product: OpenShift Container Platform Reporter: Ido Rosenzwig <irosenzw>
Component: Console Kubevirt PluginAssignee: Ido Rosenzwig <irosenzw>
Status: CLOSED ERRATA QA Contact: Guohua Ouyang <gouyang>
Severity: low Docs Contact:
Priority: low    
Version: 4.5CC: aos-bugs, gouyang
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:29:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ido Rosenzwig 2020-08-18 11:57:51 UTC
Description of problem:
When changing the boot order while the VM is running the alert at the top of the page shows a change in the disk/nic although no change has been made in the disk/nic properties.

When looking at the VM's YAML the boot order is indeed part of the device attributes but in the web UI when trying to add or modify a device there is no boot-order property. Thus, from a user perspective there it is a bit confusing.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create a VM (via YAML page)
2. change the boot order in the Details page - add a nic and move it to the top
3.

Actual results:
boot order is shown in the warning at the top of the page as well as the network interfaces and disks

Expected results:
only boot order needs to be shown

Additional info:

Comment 4 errata-xmlrpc 2020-10-27 16:29:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196