Bug 1870627

Summary: `selectId` query param not maintained when switching between topology graph and list views
Product: OpenShift Container Platform Reporter: Jeff Phillips <jephilli>
Component: Dev ConsoleAssignee: Jeff Phillips <jephilli>
Status: CLOSED ERRATA QA Contact: Jaivardhan Kumar <jakumar>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.6CC: aos-bugs, jakumar, nmukherj
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Version: 4.6.0-0.nightly-2020-08-18-165040 Cluster ID: f844bc36-a328-4dd9-adab-842f0051a000 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36
Last Closed: 2020-10-27 16:29:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeff Phillips 2020-08-20 13:35:13 UTC
Description of problem:

When switching between topology graph and list views, the selection is maintained but the URL no longer contains the `selectId` param.

When deselecting a node in topology, the URL contains an 'undefined' string.


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

1. Navigate to topology with at least one node present
2. Click the node to select it.
3. Click the node a second time to deselect it.
4. select a node
5. switch to list view

Actual results:

Upon deselecting the node, the URL contains query param `selectId=undefined`
Upon switching to list view `selectId` query param disappears 


Expected results:

URL should have no `selectId` when there are no selections.
`selectId` query param should remain consistent between topology views.


Additional info:

Comment 4 Jaivardhan Kumar 2020-08-24 12:46:01 UTC
Verified on Version: 4.6.0-0.nightly-2020-08-23-214712

Comment 6 errata-xmlrpc 2020-10-27 16:29:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196