Bug 1871683

Summary: Need a more clear event message for ebs.csi.aws.com provisioner
Product: OpenShift Container Platform Reporter: Qin Ping <piqin>
Component: StorageAssignee: Christian Huffman <chuffman>
Storage sub component: Operators QA Contact: Qin Ping <piqin>
Status: CLOSED ERRATA Docs Contact:
Severity: low    
Priority: low CC: aos-bugs, chuffman
Version: 4.6   
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:31:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Qin Ping 2020-08-24 03:33:24 UTC
Description of problem:
Need a more clear event message for ebs.csi.aws.com provisioner
Storage

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-23-185640

How reproducible:
Always

Steps to Reproduce:
1. Install an OCP4.6 cluster on AWS
2. Clone a storage class with ebs.csi.aws.com provisioner and Immediate bind mode.
3. Create a PVC with "RWX" or "ROX" access modes

Actual results:
PVC is in pending status and gets the following event:
Warning  ProvisioningFailed    <invalid> (x6 over <invalid>)  ebs.csi.aws.com_ip-10-0-49-238.us-east-2.compute.internal_003d900a-1a4e-43e0-ae5e-3da6bbe2c24d  failed to provision volume with StorageClass "gp2-csi-i": rpc error: code = InvalidArgument desc = Volume capabilities not supported

Expected results:
The event for internel provisioner "kubernetes.io/aws-ebs" is:
Warning  ProvisioningFailed  <invalid>  persistentvolume-controller  Failed to provision volume with StorageClass "gp2-i": invalid AccessModes [ReadWriteMany]: only AccessModes [ReadWriteOnce] are supported

The event for internal provisioner is more clear.

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Christian Huffman 2020-08-26 19:28:50 UTC
I've submitted [1] to address this issue upstream. Once it's merged we can backport it into our driver.

[1] https://github.com/kubernetes-sigs/aws-ebs-csi-driver/pull/550

Comment 5 Qin Ping 2020-09-27 06:01:07 UTC
Verified with: 4.6.0-0.nightly-2020-09-26-202331

failed to provision volume with StorageClass "gp2-csi": rpc error: code = InvalidArgument desc = Volume capabilities MULTI_NODE_MULTI_WRITER not supported. Only AccessModes[ReadWriteOnce] supported.

Comment 8 errata-xmlrpc 2020-10-27 16:31:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196