Bug 1871940

Summary: No indication of resource filtering in Topology view
Product: OpenShift Container Platform Reporter: Jeff Phillips <jephilli>
Component: Dev ConsoleAssignee: Jeff Phillips <jephilli>
Status: CLOSED ERRATA QA Contact: Gajanan More <gamore>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.6CC: aos-bugs, nmukherj
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Version: 4.6.0-0.nightly-2020-08-02-134243 Cluster ID: cce252ee-794f-4a18-b659-b3b2357b86d4 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36
Last Closed: 2020-10-27 16:31:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Verification of bug 1871940 none

Description Jeff Phillips 2020-08-24 16:20:40 UTC
Description of problem:

Currently, there is no indication that a resource is being filtered if the dropdown is closed. UX recommends that there should be a number badge on the top of the dropdown indicating how many resources are being filtered. The number badges indicating how many of each resource there is inside the dropdown should be changed to numbers within parentheses to not cause confusion between the number badges

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. Navigate to the Developer perspective, Topology view
2. Select 'Filter by Resource`
3. Select a resource to filter by

Actual results:

Resources are filtered but no way to know that there is a filter being applied.

Expected results:

Resources are filtered and there is an indication that some limited number of resource types are being shown.

Additional info:

Comment 3 Abhishek K N 2020-09-03 09:12:13 UTC
PSA. Filter by Resource dropdown now has number badge on the top of the dropdown indicating how many resources are being filtered. And resource count is now shown within parentheses.

Verified on build:
  OpenShift Version: 4.6.0-0.nightly-2020-09-02-210353
  Kubernetes Version: v1.19.0-rc.2+b5dc585-dirty

Comment 4 Abhishek K N 2020-09-03 09:14:38 UTC
Created attachment 1713568 [details]
Verification of bug 1871940

Comment 6 errata-xmlrpc 2020-10-27 16:31:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196