Bug 1871970

Summary: [OSP] Haproxy config inconsistent with other on-prem platforms
Product: OpenShift Container Platform Reporter: Martin André <m.andre>
Component: Machine Config OperatorAssignee: Martin André <m.andre>
Status: CLOSED ERRATA QA Contact: David Sanz <dsanzmor>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.6CC: bperkins
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:31:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin André 2020-08-24 17:55:10 UTC
Description of problem: The HAProxy configuration for OpenStack platforms has diverged from the other on-prem platforms. 

This is believed to be the reason for the high frequency of flakes for `[sig-api-machinery] API data in etcd should be stored at the correct location and version for all resources [Serial]` test observed on OpenStack platform and reported at https://bugzilla.redhat.com/show_bug.cgi?id=1870247.

The haproxy configuration should be consistent across platforms to prevent issues like this one and ease trouble-shoot in the future.

Comment 3 David Sanz 2020-08-27 10:08:21 UTC
Verified on 4.6.0-0.nightly-2020-08-27-005538

Comment 5 errata-xmlrpc 2020-10-27 16:31:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196