Bug 1872145

Summary: Disable power actions if BMO is not running
Product: OpenShift Container Platform Reporter: Rastislav Wagner <rawagner>
Component: Console Metal3 PluginAssignee: Rastislav Wagner <rawagner>
Status: CLOSED ERRATA QA Contact: Yanping Zhang <yanpzhan>
Severity: medium Docs Contact:
Priority: high    
Version: 4.6CC: aos-bugs, jtomasek, yapei
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:32:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rastislav Wagner 2020-08-25 07:54:37 UTC
Description of problem:
If BMO is not running power actions on BMH should be disabled

Comment 3 Rastislav Wagner 2020-09-18 07:18:21 UTC
Little bit more info: BMO is not running if there's no provisioning-configuration CR (BMO pods are running, but BMO is disabled due to missing CR).

Comment 4 Yadan Pei 2020-09-29 05:47:36 UTC
1. Delete provisioning.metal3.io instance with name provisioning-configuration
$ oc delete provisioning.metal3.io provisioning-configuration

2. Check BMH action menus, these actions are disabled(invisible): Deprovision, Power Off, Restart

Moving to VERIFIED 4.6.0-0.nightly-2020-09-27-075304

Comment 7 errata-xmlrpc 2020-10-27 16:32:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196