Bug 1872629

Summary: Cluster with small block of IP addrresses - range of machineCIDR
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: InstallerAssignee: Martin André <m.andre>
Installer sub component: OpenShift on OpenStack QA Contact: David Sanz <dsanzmor>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: elavarde, m.andre, pprinett, racedoro
Version: 4.5Keywords: UpcomingSprint
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: A value of 16000 nodes was set when calculating the end of DHCP allocation pool when provisioning the nodes subnet. Consequence: deploying OpenShift on OpenStack platform with a machine CIDR smaller than /18 resulted in an error. Fix: stop hardcoding the number of nodes and instead dynamically calculate the end of DHCP allocation pool. Result: it is now possible to deploy OpenShift on OpenStack with machine CIDR of any length, provided it is large enough to for all needed nodes.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-09-21 17:42:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1871048    
Bug Blocks:    

Comment 4 David Sanz 2020-09-14 09:12:15 UTC
Verified on 4.5.0-0.nightly-2020-09-14-030924

[core@mrnd-13-45-rm5j6-bootstrap ~]$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1450 qdisc fq_codel state UP group default qlen 1000
    link/ether fa:16:3e:b4:33:16 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.123/24 brd 192.168.0.255 scope global dynamic noprefixroute ens3
       valid_lft 86194sec preferred_lft 86194sec
    inet 192.168.0.6/24 scope global secondary ens3
       valid_lft forever preferred_lft forever
    inet 192.168.0.5/24 scope global secondary ens3
       valid_lft forever preferred_lft forever
    inet6 fe80::242e:3a21:c812:5b31/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
[core@mrnd-13-45-rm5j6-bootstrap ~]$

Comment 6 errata-xmlrpc 2020-09-21 17:42:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719