Bug 1872686

Summary: Avoid pulling in lxpolkit to Fedora Workstation default install
Product: [Fedora] Fedora Reporter: Kalev Lember <klember>
Component: gnome-shellAssignee: Florian Müllner <fmuellner>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: awilliam, ego.cordatus, fmuellner, gnome-sig, jadahl, otaylor, philip.wyett
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: gnome-shell-3.37.91-2.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-31 20:08:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1766776    

Description Kalev Lember 2020-08-26 12:30:21 UTC
Right now Fedora Workstation images include lxpolkit. This is incorrect because gnome-shell has a built-in policykit authentication agent and the LXDE lxpolkit agent isn't needed.

It turned out to be due to blivet-gui-runtime requiring virtual PolicyKit-authentication-agent, but gnome-shell didn't have the virtual provides for it.

gnome-shell-3.37.91-2.fc33 adds the virtual provides. Would be nice to pull this in to the Beta compose to test this out and possibly reduce the package set a tiny bit.

It's unclear if lxpolkit being present can cause any issues (race with gnome-shell's polkit agent startup?) -- I suspect no, but would be better to drop it just in case.

Comment 1 Fedora Update System 2020-08-26 12:31:34 UTC
FEDORA-2020-a587f2e4db has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a587f2e4db

Comment 2 Fedora Update System 2020-08-26 17:07:21 UTC
FEDORA-2020-a587f2e4db has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a587f2e4db`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a587f2e4db

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Adam Williamson 2020-08-26 18:07:09 UTC
We have +3 in the voting ticket: https://pagure.io/fedora-qa/blocker-review/issue/41

so setting accepted.

Comment 4 Fedora Update System 2020-08-31 20:08:36 UTC
FEDORA-2020-a587f2e4db has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.