Bug 1873123

Summary: Default install-config.yaml includes deprecated parameters
Product: OpenShift Container Platform Reporter: Martin André <m.andre>
Component: InstallerAssignee: Mike Fedosin <mfedosin>
Installer sub component: OpenShift on OpenStack QA Contact: David Sanz <dsanzmor>
Status: CLOSED ERRATA Docs Contact:
Severity: low    
Priority: low CC: pprinett
Version: 4.6Keywords: UpcomingSprint
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:35:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin André 2020-08-27 12:43:21 UTC
Description of problem:

The install-config.yaml that is generated via the `openshift-install create install-config` command contains deprecated parameters:
- octaviaSupport
- region
- trunkSupport

All set to empty string.

We need to stop adding the deprecated parameters when writing the install-config.yaml file to disk.

Comment 4 David Sanz 2020-08-28 10:02:37 UTC
Verified on 4.6.0-0.nightly-2020-08-28-042424

platform:
  openstack:
    apiVIP: 10.0.0.5
    cloud: xxxx
    computeFlavor: xxxxx
    externalDNS: null
    externalNetwork: xxxxx
    ingressVIP: 10.0.0.7

Comment 6 errata-xmlrpc 2020-10-27 16:35:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196