Bug 1873192

Summary: show empty state for monitoring charts when no datapoints available
Product: OpenShift Container Platform Reporter: Aritra Roy <ariroy>
Component: Dev ConsoleAssignee: Aritra Roy <ariroy>
Status: CLOSED ERRATA QA Contact: Jaivardhan Kumar <jakumar>
Severity: high Docs Contact:
Priority: medium    
Version: 4.5CC: aos-bugs, jakumar, nmukherj
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:35:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
empty state when no datapoint for chart none

Description Aritra Roy 2020-08-27 15:21:28 UTC
Created attachment 1712844 [details]
empty state when no datapoint for chart

Description of problem:
the monitoring tab shows empty charts when there are no datapoints available

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-01-202952

How reproducible:
always

Steps to Reproduce:
1.scale a workload to zero pods
2.go to the monitoring tab of topology sidepanel

Actual results:
empty charts shown

Expected results:
empty state should be shown

Additional info:

Comment 2 Jaivardhan Kumar 2020-09-23 11:10:43 UTC
Verified on Version: 4.6.0-0.nightly-2020-09-22-213802

Comment 5 errata-xmlrpc 2020-10-27 16:35:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196