Bug 1873582

Summary: Quick starts do not have access review checks
Product: OpenShift Container Platform Reporter: Rohit Rai <rorai>
Component: Dev ConsoleAssignee: Rohit Rai <rorai>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: high Docs Contact:
Priority: high    
Version: 4.6CC: aos-bugs, nmukherj, spathak
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:35:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Without pipeline operator
none
With pipeline operator none

Description Rohit Rai 2020-08-28 16:45:55 UTC
Description of problem:

We need to show tours to users based on their permissions. We also need to hide tours based on Operator presence. We should use the same flags to disable the operator install tours which we'll use to enable the tours which depend on operator being installed.
 

    If operator is not installed show install operator tour.
    If operator is installed show create application tours and disable/hide install operator tour.
    Prerequisites (if any, like setup, operators/versions):
    Steps to Reproduce

    Go to quick starts page

Actual results:

All tours are shown
Expected results:

Tours should be shown based on the above requirements.
Reproducibility (Always/Intermittent/Only Once):

Always
Build Details:

Comment 2 spathak@redhat.com 2020-09-20 22:13:24 UTC
Created attachment 1715475 [details]
Without pipeline operator

Comment 3 spathak@redhat.com 2020-09-20 22:14:14 UTC
Created attachment 1715476 [details]
With pipeline operator

Comment 4 spathak@redhat.com 2020-09-20 22:14:51 UTC
Verify on build version: 4.6.0-0.ci-2020-09-19-115132
Browser version: Chrome 84

Comment 7 errata-xmlrpc 2020-10-27 16:35:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196