Bug 1873878

Summary: Fedora package outdated vs upstream
Product: [Fedora] Fedora Reporter: thedatum+bz
Component: android-toolsAssignee: Ivan Afonichev <ivan.afonichev>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 34CC: admiller, gabibbo97, ivan.afonichev, jeroen, joe, leonfauster, peterplatek, thedatum+bz
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: android-tools-30.0.5p1-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-02 01:21:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description thedatum+bz 2020-08-30 18:16:45 UTC
The last update of the `android-tools` package to an upstream commit was 2 years ago with version 20180828gitc7815d675: https://src.fedoraproject.org/rpms/android-tools/commits/master

Meanwhile, the SDK Platform Tools is regularly updated: https://developer.android.com/studio/releases/platform-tools

Is there a reason for this hold-up?

Comment 1 Ivan Afonichev 2020-08-30 19:09:56 UTC
I work on building latest upstream, but it takes time as need to rewrite our self made build scripts to represent current upstream ones. We cannot build using upstream build system as it is not present in fedora.

Comment 2 thedatum+bz 2020-08-30 20:23:51 UTC
Thanks for the quick reply. 

I can understand some lag between upstream and Fedora packaging, but a 2 year delay has the appearance of an abandoned project. 

Is an update expected soon?

Comment 3 Ivan Afonichev 2020-08-30 21:27:16 UTC
I hope it will happen soon.
As google refactor code several times per month and those refactoring require our build scripts changes it is worse to update android-tools only in case some features are needed.

Currently I see some fastboot commands don't work properly on some recent devices, thats why it's time to update android-tools. Also having such requests is another reason to work on it.

Current status if you are interested in: mock android build system version generation(as we don't have android build system in fedora).

Comment 4 thedatum+bz 2020-08-31 03:23:45 UTC
It's too bad the android build system (Soong?) is unavailable in Fedora. It would be a nice to have a more robust and less time-consuming method than custom build scripts.

In the meantime, thank you for your efforts. I, and I am sure others too, will be looking forward to the updated android-tools package.

Comment 5 Peter Platek 2021-01-28 17:12:18 UTC
I would like to add my +1 on this issue.  

It seems MacOS homebrew has the latest version of adb (Android Debug Bridge version 1.0.41 Version 30.0.0-6374843) which makes the client incompatible with adb server when used by calling `adb -H <adb-server-ip>`

I get this when trying:
adb server version (40) doesn't match this client (41); killing...
ADB server didn't ACK
Full server startup log: /var/folders/tz/9fp25clj1gvc66rv551bwm1m0000gn/T//adb.501.log
Server had pid: 72642
--- adb starting (pid 72642) ---
adb I 01-28 12:08:28 72642 20547628 main.cpp:62] Android Debug Bridge version 1.0.41
adb I 01-28 12:08:28 72642 20547628 main.cpp:62] Version 30.0.0-6374843
adb I 01-28 12:08:28 72642 20547628 main.cpp:62] Installed as /usr/local/bin/adb
adb I 01-28 12:08:28 72642 20547628 main.cpp:62] 
adb F 01-28 12:08:29 72642 20547628 main.cpp:148] could not install *smartsocket* listener: listening on specified hostname currently unsupported

* failed to start daemon
adb: failed to check server version: cannot connect to daemon

Anyway, it would be awesome if we could get a more recent version.

Comment 6 Joseph D. Wagner 2021-02-21 00:13:33 UTC
This bug also impacts version 33. Could version be changed so this bug doesn't hit end of life? Or should I clone this bug report?

Comment 7 thedatum+bz 2021-02-21 01:04:30 UTC
(In reply to Joseph D. Wagner from comment #6)
> This bug also impacts version 33. Could version be changed so this bug
> doesn't hit end of life? Or should I clone this bug report?

I've updated the bug report to F33. The android-tools package has still not been updated.

Comment 8 Leon Fauster 2021-03-08 18:28:18 UTC
The current fedora version of android-tools does not build with clang11 



Mageia 8 was recently released with android-tools 10 and clang 11. Maybe a source of inspiration?


I tried to build on COPR but some macros mismatched ...

Comment 9 Ivan Afonichev 2021-03-09 22:52:57 UTC
Yes, that's definetely insteresting, thanks a lot for sharing!
I'll try to build it in fedora.
Looks like it's most promising way to preserve android-tools in f34.

Comment 10 Fedora Update System 2021-03-24 20:06:39 UTC
FEDORA-2021-0dda64cc5d has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-0dda64cc5d

Comment 11 Fedora Update System 2021-03-25 01:32:24 UTC
FEDORA-2021-0dda64cc5d has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-0dda64cc5d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-0dda64cc5d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-04-02 01:21:09 UTC
FEDORA-2021-0dda64cc5d has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 thedatum+bz 2021-05-25 01:25:49 UTC
The updated package worked for Fedora 33, but the package for Fedora 34 is still the old one from 2018. Could the update please be pushed to Fedora 34 too?