Bug 1874112

Summary: Telemeter Server Authorization upstream error codes
Product: OpenShift Container Platform Reporter: Matthias Loibl <mloibl>
Component: MonitoringAssignee: Matthias Loibl <mloibl>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: low Docs Contact:
Priority: high    
Version: 4.6CC: alegrand, anpicker, erooth, kakkoyun, lcosic, lserven, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:36:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matthias Loibl 2020-08-31 15:25:31 UTC
Description of problem:
The Telemeter server actually returns 500 if the upstream Tollbooth returns unknowns 4xx. That's bad because it might wake up SREs.

Version-Release number of selected component (if applicable):
4.6

How reproducible:
100%

Steps to Reproduce:
1. Send too many invalid pull secrets.

Actual results:
Telemeter Server returns 500.

Expected results:
Telemeter Server should return the 4xx sent by the upstream.

Additional info:
https://github.com/openshift/telemeter/blob/958dc61aad8433789e6140c5d97e5a99ce7a3dd8/pkg/authorize/jwt/handler.go#L91

Comment 7 errata-xmlrpc 2020-10-27 16:36:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196