Bug 1874890

Summary: Accessibility - The grey circle next to “Control Plane” has no text description, label, or other accessible information
Product: OpenShift Container Platform Reporter: Cyril <cajieh>
Component: Management ConsoleAssignee: Steve Goodwin <sgoodwin>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: aos-bugs, jokerman, schituku, sgoodwin, spadgett
Target Milestone: ---Keywords: UpcomingSprint
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:37:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Control Plane
none
ScreenShot with the alt text none

Description Cyril 2020-09-02 13:58:27 UTC
Created attachment 1713444 [details]
Control Plane

Description of problem:
Warning: the grey circle next to “Control Plane” has no text description, label, or other accessible information; it is not merely decorative as it is indicative of a background operation in progress. This pattern is used through the web interface, generally where content is still loading; text, alt-text, or other non-visual indicator should also be used.



Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-02-134243

How reproducible:
Always

Steps to Reproduce:
1. Goto to Overview page
2. No text description, label, or other accessible information associated with the grey circle next to “Control Plane”


Actual results:
No text description, label, or other accessible information associated with the grey circle next to “Control Plane”

Expected results:
Should have text description, label, or other accessible information


Additional info:

Comment 1 Samuel Padgett 2020-09-03 13:05:12 UTC
I think this is a misapplication of the loading skeleton. The skeleton is meant to be a loading indicator for entire sections of the UI, not individual icons or rows as we use it on this page. We might consider either leaving the skeleton for the entire section until all content loads, or possibly not showing the label at all until the status loads if we want more incremental loading.

Comment 2 Steve Goodwin 2020-09-15 17:31:23 UTC
(In reply to Samuel Padgett from comment #1)
> I think this is a misapplication of the loading skeleton. The skeleton is
> meant to be a loading indicator for entire sections of the UI, not
> individual icons or rows as we use it on this page. We might consider either
> leaving the skeleton for the entire section until all content loads, or
> possibly not showing the label at all until the status loads if we want more
> incremental loading.


Do we have a way to restrict entire sections from displaying until all page content is loaded? Are there any pages that behave that way currently? 

It seems reasonable that a dashboard would load the ui based on data retrieval. And include `aria-label` and `role`
<div className="skeleton-health" aria-label="loading component status" role="status" />

Comment 4 Siva Reddy 2020-10-06 09:52:35 UTC
There is an alt for the indicators on the Overview page. Hence moving this to verified state.

Version:
  4.6.0-0.nightly-2020-10-03-032912

Steps to verify:
1. Login to web console 
2. Navigate to PageSideBar>Home>Overview page
3. Notice in Cluster Status tile the status icon next to Cluster, Control panel and Operators.
4. Hover over the icons and their status text will be displayed.

 attached screenshot that shows the fix.

Comment 5 Siva Reddy 2020-10-06 10:00:13 UTC
Created attachment 1719318 [details]
ScreenShot with the alt text

Comment 8 errata-xmlrpc 2020-10-27 16:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196