Bug 1875345

Summary: Query Browser: JS error in DevTools console when metric label key is `id`
Product: OpenShift Container Platform Reporter: Andrew Pickering <anpicker>
Component: MonitoringAssignee: Andrew Pickering <anpicker>
Status: CLOSED ERRATA QA Contact: hongyan li <hongyli>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.6CC: alegrand, anpicker, erooth, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:37:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andrew Pickering 2020-09-03 11:21:17 UTC
JS error message and relevant part of the stack trace is below.

Warning: Encountered two children with the same key, `[object Object]-row`. Keys should be unique so that components maintain their identity across updates. Non-unique keys may cause children to be duplicated and/or omitted — the behavior is unsupported and could change in a future version.
    in tbody (created by BodyWrapper)
    in BodyWrapper (created by BaseBody)
    in BaseBody (created by Context.Consumer)
    in Body (created by ContextBody)
    in ContextBody (created by Context.Consumer)
    in TableBody (created by QueryTable_)
    in table (created by Provider)
    in Provider (created by Table)
    in Table (created by QueryTable_)
    in div (created by QueryTable_)
    in QueryTable_ (created by ConnectFunction)
    in ConnectFunction (created by Query_)
    in div (created by Query_)
    in Query_ (created by ConnectFunction)
    in ConnectFunction (created by QueriesList_)
    in QueriesList_ (created by ConnectFunction)
    in ConnectFunction (created by QueryBrowserPage_)
    in div (created by QueryBrowserPage_)
    in div (created by QueryBrowserPage_)
    in div (created by QueryBrowserPage_)
    in QueryBrowserPage_ (created by ConnectFunction)
    in ConnectFunction
    in ErrorBoundary

Comment 4 hongyan li 2020-09-10 04:30:43 UTC
Test with payload 4.6.0-0.nightly-2020-09-09-173545
From dev console, query metrics container_memory_failures_total and container_fs_reads_bytes_total which has id label, data display well, no js error.

Comment 6 errata-xmlrpc 2020-10-27 16:37:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196