Bug 1875558

Summary: BareMetalHost resources are not always deleted
Product: OpenShift Container Platform Reporter: Doug Hellmann <dhellmann>
Component: Bare Metal Hardware ProvisioningAssignee: Doug Hellmann <dhellmann>
Bare Metal Hardware Provisioning sub component: baremetal-operator QA Contact: Daniel <dmaizel>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: medium CC: beth.white, rbartal, tsedovic, zbitter
Version: 4.6Keywords: Triaged
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 16:37:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1874599    

Description Doug Hellmann 2020-09-03 18:41:37 UTC
Description of problem:

Upstream bug https://github.com/metal3-io/baremetal-operator/issues/482 says that if hosts are registered and then deleted quickly in succession the host is not actually removed.

Version-Release number of selected component (if applicable):

4.6

How reproducible:

Reliably, but it's tricky to get the timing right.

Steps to Reproduce:
1. Create the host and then delete it immediately

Actual results:

Errors in the log and the host is not deleted.

Expected results:

The host is cleanly deleted.

Additional info:

Comment 5 errata-xmlrpc 2020-10-27 16:37:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196