Bug 1875946

Summary: Using shareProcessNamespace with default pod image leaves unreaped processes
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: NodeAssignee: Peter Hunt <pehunt>
Node sub component: CRI-O QA Contact: Weinan Liu <weinliu>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: aos-bugs, jokerman, mmethot, mpatel, weinliu
Version: 4.6   
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1900725 1900727 (view as bug list) Environment:
Last Closed: 2020-10-27 16:37:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1900725    

Description Clayton Coleman 2020-09-04 16:59:28 UTC
A community member reported that the pod image does not correctly reap readiness checks when pods are used with shareProcessNamespace.  In the future we may use a systemd image, but for now our pod image should work correctly.

We need to review the change and verify it is equivalent to pause.c in upstream Kubernetes.

Comment 1 Mrunal Patel 2020-09-11 18:49:24 UTC
I have tested the PR and left review comments which are being addressed. It is close to getting merged. Hopefully, it will land today or early next week and be available for testing.

Comment 6 errata-xmlrpc 2020-10-27 16:37:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196