Bug 1876025

Summary: clidownloads mistakenly lists IBM Power and Z as unsupported [4.5]
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: Siva Reddy <schituku>
Severity: low Docs Contact:
Priority: low    
Version: 4.6CC: aos-bugs, jokerman, spadgett, yapei, yselkowi
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-10 14:53:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1875969    
Bug Blocks:    
Attachments:
Description Flags
screen shot showing the cli downloads none

Description OpenShift BugZilla Robot 2020-09-04 23:52:13 UTC
+++ This bug was initially created as a clone of Bug #1875969 +++

IBM Z has been supported since 4.2.z and Power since 4.3.z, so should not be listed as unsupported in clidownloads.

Comment 6 Siva Reddy 2020-11-05 01:56:02 UTC
The Download oc for Linux for IBM Z and IBM Power is showing in the Console  cli tools downloads without the "unsupported" annotation.

Version:
4.5.0-0.nightly-2020-11-04-215039

Steps to verify:

1. Login to web console
2. Click on the "?" help icon on the top right corner and navigate to Command Line Tools option
3. verify that the "Download oc for Linux for IBM Z" and "Download oc for Linux for IBM Power" are without the "unsupported" word in parentheses.

Hence moving this bug to verify status. attaching the screen shot.

Comment 7 Siva Reddy 2020-11-05 01:56:56 UTC
Created attachment 1726773 [details]
screen shot showing the cli downloads

Comment 9 errata-xmlrpc 2020-11-10 14:53:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4425