Bug 187702

Summary: Names incorrect for includes and apr-config
Product: [Fedora] Fedora Reporter: Paul F. Johnson <paul>
Component: aprAssignee: Joe Orton <jorton>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-03 07:23:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Paul F. Johnson 2006-04-03 00:06:08 UTC
Description of problem:
I'm trying to compile mod_mono for inclusion into FE. The configuration file
looks for /usr/bin/apr-config and /usr/include/apr, however, the current
versions in FC5 and rawhide have changed the names to apr-1-config and
/usr/include/apr-1 which causes the configuration script a multitude of headaches.

Version-Release number of selected component (if applicable):
apr-1.2.2-7.2

How reproducible:
Always

Steps to Reproduce:
1. Download mod_mono from http://go-mono.com/packages
2. Run the configure script
3.
  
Actual results:
The script bombs due to apr-config and /usr/include/apr not being named as expected

Expected results:
The configure script should run

Additional info:
If I do ln -s /usr/bin/apr-1-config /usr/bin/apr-config and
/usr/include/apr-1 /usr/include/apr

the configure script works.

Comment 1 Joe Orton 2006-04-03 07:23:33 UTC
That's the difference between APR 1.x and APR 0.9.x - mod_mono needs to be
ported to the former.

Comment 2 Paul F. Johnson 2006-04-03 07:49:34 UTC
Should make for an interesting hour's work...

Out of interest, when apr-2 comes out, will apr-config et al change to apr-2?
I'm still at a loss for the requirement for the name change given the likes of
wx-config and gtk-config both don't use the version number.

Comment 3 Joe Orton 2006-04-03 13:14:48 UTC
It's to allow parallel installation of the apr-0.9 and apr-1.x packages. 
glib/gtk et al deprecated the use of the -config files in the newer major
version, which avoids the problem. (and the equivalent pkg-config files are
versioned)

Comment 4 Joe Orton 2006-04-03 13:15:55 UTC
Oh, and yes, the number will change to 2 with apr-2.  But you don't know whether
the current mod_mono sources will work with APR 2.x so I don't think it would be
correct to proactively search for that.