Bug 1879181

Summary: "openshift-install destroy cluster" is not documented
Product: OpenShift Container Platform Reporter: Jan Safranek <jsafrane>
Component: DocumentationAssignee: Lisa Pettyjohn <lpettyjo>
Status: CLOSED WONTFIX QA Contact: Xiaoli Tian <xtian>
Severity: medium Docs Contact: Vikram Goyal <vigoyal>
Priority: unspecified    
Version: 4.6CC: aos-bugs, bfuru, gzaidman, jokerman
Target Milestone: ---   
Target Release: 4.7.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-17 07:51:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Safranek 2020-09-15 15:50:09 UTC
Describe the issue: 

Command "openshift-install destroy cluster" is not documented at all.

The command has quite important consequence: it destroys all volumes provisioned in the cluster*. While nobody will miss a VM or a network after destroying a cluster, users should be warned in our docs that volumes are destroyed too. They should back up their precious data before running the command.

*) On some cloud platforms, we can't destroy the volumes (it's technically not possible to distinguish volumes that were provisioned for the cluster from other volumes). Again, users should know that they are expected to find and delete the volumes by themselves. Current platforms where we can't delete volumes are:

- bare metal
- oVirt
- vSphere
- Any storage provided by 3rd party storage backend that is not part of the cloud platform (various storage appliances, Openshift Container Storage, ...)

Comment 1 Jan Safranek 2020-09-15 15:50:52 UTC
While it would be nice to backport such documentation to all supported releases, it does not block 4.6

Comment 3 Gal Zaidman 2021-10-17 07:51:37 UTC
Closing this since it is an old issue that is not handled.
I personally don't think it should be documented since it expects a path to an directory containing the metadata.json file which is created on the installation, usually, the openshift user will not save this file for later usage and I think it will cause more confusion for users then benefit.