Bug 1881073

Summary: [RFE] config-download collection support
Product: Red Hat OpenStack Reporter: Luke Short <lshort>
Component: python-tripleoclientAssignee: Luke Short <lshort>
Status: CLOSED WONTFIX QA Contact: David Rosenfeld <drosenfe>
Severity: medium Docs Contact:
Priority: medium    
Version: 16.2 (Train)CC: hbrock, jslagle, mburns
Target Milestone: betaKeywords: FutureFeature, Triaged
Target Release: 16.2 (Train on RHEL 8.4)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-30 18:28:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Luke Short 2020-09-21 13:53:05 UTC
Description of problem:
The deployment files from `openstack overcloud config download` are not portable. Starting with Ansible 2.8 (and especially now with the release of 2.10), there is a huge focus on portable and consumable collections.


Version-Release number of selected component (if applicable):
RHOSP <= 16.1


How reproducible:
100%


Steps to Reproduce:
1. `openstack overcloud config download`
2. Move the directory it creates to another server (or into Ansible Tower).
3. Execute the playbooks. They will fail because there are missing roles and modules.


Actual results:
`openstack overcloud config download` only provides the task files that are generated from THT.


Expected results:
All of the required dependencies (including roles and modules) should be copied over to the config-download directory.
```
$ openstack overcloud config download --collection
$ ls -1 tripleo-ansible
roles
modules
...
```


Additional info:
Related spec for Ansible Tower (AWX) integration: https://review.opendev.org/#/c/698828/

Comment 4 Luke Short 2020-10-30 18:28:35 UTC
Per discussions during the Wallaby PTG, this will no longer be pursued.

https://etherpad.opendev.org/p/ptg-tripleo-config-download-collection