Bug 1881830

Summary: SDN pod in crashloopbackoff state after upgrade from 4.4 -> 4.5 with multiple value of clusterCIDR
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NetworkingAssignee: Surya Seetharaman <surya>
Networking sub component: openshift-sdn QA Contact: zhaozhanqi <zzhao>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: urgent CC: aconstan, erich, jkaur, mharri, mvardhan, palonsor, sreber, surya, swasthan, toni.tauro
Version: 4.5Keywords: Triaged
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Kube-proxy does not support multiple clusterCIDRs to detect local traffic. So when multiple-cidrs are configured in openshift-sdn the CNO sets KubeProxyConfiguration.clusterCIDR field as empty. Until 4.4 the empty clusterCIDR value was ignored but from 4.5 we started to fail if an empty value was passed. Consequence: After upgrade from 4.4 to 4.5 the sdn-config ConfigMap has field (clusterCIDR: "") , an empty string and fails to parse causing the sdn pods to remain in crashloopbackoff state. Fix: Like in 4.4, we continue to ignore if the value is empty instead of failing and call the dummy no-op local traffic detector instead. This was fixed in 4.6 and backported to 4.5. Result: SDN pods don't crash if multiple cidrs are set.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-19 14:54:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1877794    
Bug Blocks:    

Comment 2 zhaozhanqi 2020-10-09 06:42:26 UTC
Verified this bug on 4.5.0-0.nightly-2020-10-08-234154 upgrade from 4.4.27

Comment 5 errata-xmlrpc 2020-10-19 14:54:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4228