Bug 1882066

Summary: [ovn][upgrade][4.4]Failed to upgrade for ovn network plugin
Product: OpenShift Container Platform Reporter: Ben Bennett <bbennett>
Component: NetworkingAssignee: Ben Bennett <bbennett>
Networking sub component: ovn-kubernetes QA Contact: Anurag saxena <anusaxen>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: urgent CC: aconstan, anusaxen, huirwang, rbrattai, sdodson, vlaad, weliang, wking, yuxzhu, zhsun, zzhao
Version: 4.5Keywords: Regression, TestBlocker
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1874928 Environment:
Last Closed: 2020-10-01 17:50:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1874928    
Bug Blocks:    

Comment 1 Alexander Constantinescu 2020-09-23 18:53:51 UTC
Removing dependency on 1882092, since it's more the other way around.

Comment 4 Anurag saxena 2020-09-24 16:02:53 UTC
Version looks as what we see in merged PR

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-09-24-095123   True        False         28m     Cluster version is 4.4.0-0.nightly-2020-09-24-095123

$ oc rsh ovnkube-master-zs4s7
Defaulting container name to northd.
Use 'oc describe pod/ovnkube-master-zs4s7 -n openshift-ovn-kubernetes' to see all of the containers in this pod.
sh-4.2# rpm -qa |grep -i ovn
ovn2.13-20.06.2-4.el7fdp.x86_64
ovn2.13-central-20.06.2-4.el7fdp.x86_64
ovn2.13-host-20.06.2-4.el7fdp.x86_64
ovn2.13-vtep-20.06.2-4.el7fdp.x86_64
sh-4.2# exit
exit

Comment 5 zhaozhanqi 2020-09-25 07:12:01 UTC
Verified this bug on 4.4.0-0.nightly-2020-09-24-222539

Comment 7 errata-xmlrpc 2020-10-01 17:50:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.26 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3764

Comment 8 W. Trevor King 2021-04-05 17:47:58 UTC
Removing UpgradeBlocker from this older bug, to remove it from the suspect queue described in [1].  If you feel like this bug still needs to be a suspect, please add keyword again.

[1]: https://github.com/openshift/enhancements/pull/475