Bug 1885510

Summary: rpmdev-newspec produces an empty spec file
Product: [Fedora] Fedora Reporter: Pavel Raiskup <praiskup>
Component: rpmdevtoolsAssignee: Neal Gompa <ngompa13>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: bugs.michael, decathorpe, dennis, kevin, ngompa13, redhat-bugzilla, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rpmdevtools-9.2-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-06 13:12:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pavel Raiskup 2020-10-06 08:42:04 UTC
$ rpmdev-newspec 
sed: -e expression #1, char 348: unknown command: `f'
newpackage.spec created; type minimal, rpm version >= 4.16.
$ cat newpackage.spec 
$ rpm -qf /usr/bin/rpmdev-newspec
rpmdevtools-9.1-1.fc33.noarch

Comment 1 Neal Gompa 2020-10-06 13:12:10 UTC
Fixed in rpmdevtools-9.2-1.fc33

Comment 2 Pavel Raiskup 2020-10-06 13:55:25 UTC
Sorry for the dupe.

*** This bug has been marked as a duplicate of bug 1884284 ***